#1  (Permalink
Alt 10.04.2003, 23:38
GFX.de GFX.de ist offline
Mitglied
 
Registriert seit: 16.01.2000
Beiträge: 82
Standard Problem mit den $HTTP_POST_VARS

Hi zusammen,
versuche folgendes Krampfhaft mit der "neuen" $HTTP_POST_VARS Methode:

Der Kunde gibt im Formfeld einen Preis ein 900
Das Script schaut jetzt nach ob in dieser Eingabe ein Komma oder ein Punkt vorkommt, wenn nein geht man davon aus, das keine Nachkommastellen angegeben wurde.
Dies soll nun das Script machen und es so als Session speichern.

So dachte ich muß es gehen:

# Die Zahlenwerte werden mit Nachkommastellen bestückt
if (!eregi("\,",$HTTP_POST_VARS[preis]) OR !eregi("\.",$HTTP_POST_VARS[preis]))
{
$HTTP_POST_VARS["preis"] =$HTTP_POST_VARS["preis"].",00";
session_register("preis");
}

Das haut so aber leider nicht hin.
Nach dem alten Muster:
$preis = $preis."00";
gehts wunderbar.

Was soll ich nu machen....

cu
@ndre
Mit Zitat antworten
  #2  (Permalink
Alt 11.04.2003, 03:43
Benutzerbild von Jens
Jens Jens ist offline
Administrator - jdu
 
Registriert seit: 01.02.1999
Ort: Karlsdorf-Neuthard
Alter: 43
Beiträge: 8.612
Provider: Vodafone (Unitymedia BW)
Bandbreite: 550Mbit / 50Mbit
Standard

Hi,

da du von "neuer Methode" redest nehme ich an, du hast register_global in der php.ini auf off - was ja seit PHP 4.1.0 ja Standard ist. Seit genau dieser Version ist $HTTP_*_VARS veraltet und eigendlich solltest du jetzt $_POST[foo], $_GET[foo] etc. verwenden. Eine genaue Übersicht findest du unter anderem auf: http://de3.php.net/manual/de/languag...predefined.php

cu
Jens
__________________
Adam Savage, Mythbuster: "I reject your reality and substitute my own"
« Eigene Projekte: dein-ip-check.de, kostenloses iPhone App und Mein Blog»
Mit Zitat antworten
  #3  (Permalink
Alt 11.04.2003, 10:47
GFX.de GFX.de ist offline
Mitglied
 
Registriert seit: 16.01.2000
Beiträge: 82
Standard Zurück zur Problematik...

Hi,
klasse Tipp, habe gleich mal meine Scripts angefangen umzubauen.
Aber leider lösst das noch nicht mein Grundproblem.

cu
@ndre
Mit Zitat antworten
 
Anzeige
Antwort


Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)
 
Themen-Optionen Thema durchsuchen
Thema durchsuchen:

Erweiterte Suche

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit dsl und den 2 parallel geschalteten telefonen Schwadi Internet via Telefonkabel (ADSL, ADSL2+, VDSL2, SVDSL, G.FAST und SDSL) 6 05.02.2006 22:19
Problem mit den MSN Messenger Smileys Deadwalk Microsoft Windows 0 30.06.2005 14:17
Wer hat den besten Speed! Macht mit mir den Test! Alle Provider erlaubt! Ehemalige Benutzer Arcor [Archiv] 15 06.12.2002 18:44
Problem mit Windows 2000 und den Ordnern xMAIKx Microsoft Windows 5 05.08.2002 10:53
Icon-Problem mit den XP-Powertoys commy Microsoft Windows 4 31.10.2001 13:25


Alle Zeitangaben in WEZ +2. Es ist jetzt 17:11 Uhr.


Basiert auf vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.